Urgent help needed: fail to get samba information error

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Urgent help needed: fail to get samba information error

raspden
Hi There,

I've had a wretched day with the slug. First I managed to corrupt my
system hard drive in trying to copy the system to a more energy
efficient flash drive. So I decided I may as well start from scratch
and reflashed the slug with the latest unslung firmware.

All went fine until the system restarted and I started to get:

Error: Fail to get samba information.

whenever I tried to edit anything in the web GUI. I have tried
reflashing with slug several times, and have successfully unslung to
the flash drive. Everything seems to work fine through telnet. However
now I'm stuck because this error message is causing the slug not to
save any settings via the web interface. I have tried editing all
parameters and nothing is being saved. This is a problem as not only
is the servername, workgroup settings blank, but also the dns and
gateway settings meaning the slug cannot access the internet to get
the optware list.

I looked around the web and others have had this error with unslung
firmware and normal firmware. The solution they suggest is to click
'restore default config' but this does nothing on my slug but bring
the same error message up again.

I really need this sorting asap but I don't know where to start.
Perhaps I could edit settings via telnet. Which file would I need to
edit? However ultimately I need to get rid of this error in the web
interface and so if anyone has any suggestions I'd be most grateful.

On another note if anyone know how I can recover the files off my old
drive which has a corrupted EXT3 filesystem (I'm especially after conf
files which took ages to set up first time round) then please advise me.

Once again I find myself appealing for help from the good people in
this group. I really am most grateful for any help with this.

Reply | Threaded
Open this post in threaded view
|

Re: Urgent help needed: fail to get samba information error

Fernando Carolo
On Wed, Feb 20, 2008 at 7:08 PM, raspden <[hidden email]> wrote:

> Hi There,
>
>  I've had a wretched day with the slug. First I managed to corrupt my
>  system hard drive in trying to copy the system to a more energy
>  efficient flash drive. So I decided I may as well start from scratch
>  and reflashed the slug with the latest unslung firmware.
>
>  All went fine until the system restarted and I started to get:
>
>  Error: Fail to get samba information.
>
>  whenever I tried to edit anything in the web GUI. I have tried
>  reflashing with slug several times, and have successfully unslung to
>  the flash drive. Everything seems to work fine through telnet. However
>  now I'm stuck because this error message is causing the slug not to
>  save any settings via the web interface. I have tried editing all
>  parameters and nothing is being saved. This is a problem as not only
>  is the servername, workgroup settings blank, but also the dns and
>  gateway settings meaning the slug cannot access the internet to get
>  the optware list.
>
>  I looked around the web and others have had this error with unslung
>  firmware and normal firmware. The solution they suggest is to click
>  'restore default config' but this does nothing on my slug but bring
>  the same error message up again.

Hi,

you should try to reset your SysConf area, reflash the original Linksys
firmware and then restore the default configuration. This is probably the
safest way to recover from your situation. This is what you will need to
do, with links to the appropriate wiki pages that describe each step:

1. Telnet into Redboot, according to the instructions at
  http://www.nslu2-linux.org/wiki/HowTo/TelnetIntoRedBoot

2. Erase the Sysconf partition. Be very careful at this step, a typo in the
  "fis erase" command can damage other areas in the flash and prevent
  the slug from booting. See
http://www.nslu2-linux.org/wiki/HowTo/ResetSysConf.

3. Reflash the original Linksys firmware, according to
  http://www.nslu2-linux.org/wiki/HowTo/RevertToLinksysFirmware

4. Log in into the Linksys web interface and restore default settings.

From this point on, you should have the web interface working ok. After
that, feel free to install Unslung.

>  On another note if anyone know how I can recover the files off my old
>  drive which has a corrupted EXT3 filesystem (I'm especially after conf
>  files which took ages to set up first time round) then please advise me.

If you have a Linux machine, simply attach the drive to it and run fsck. If
you don't have a Linux box, get a live CD from Ubuntu, boot from it and
you will be able to run fsck on your drive. Please remember that fsck can
only fix the structure of the file system, there is no guarantee that you
will get all your data back, but it is your best bet.

Regards,

--
Fernando Carolo
"Ignore the noise. Make some signal" -- Nathan Torkington
Reply | Threaded
Open this post in threaded view
|

Re: Urgent help needed: fail to get samba information error

raspden
--- In [hidden email], "Fernando Carolo" <carolo@...> wrote:

>
> On Wed, Feb 20, 2008 at 7:08 PM, raspden <raspden@...> wrote:
> > Hi There,
> >
> >  I've had a wretched day with the slug. First I managed to corrupt my
> >  system hard drive in trying to copy the system to a more energy
> >  efficient flash drive. So I decided I may as well start from scratch
> >  and reflashed the slug with the latest unslung firmware.
> >
> >  All went fine until the system restarted and I started to get:
> >
> >  Error: Fail to get samba information.
> >
> >  whenever I tried to edit anything in the web GUI. I have tried
> >  reflashing with slug several times, and have successfully unslung to
> >  the flash drive. Everything seems to work fine through telnet.
However

> >  now I'm stuck because this error message is causing the slug not to
> >  save any settings via the web interface. I have tried editing all
> >  parameters and nothing is being saved. This is a problem as not only
> >  is the servername, workgroup settings blank, but also the dns and
> >  gateway settings meaning the slug cannot access the internet to get
> >  the optware list.
> >
> >  I looked around the web and others have had this error with unslung
> >  firmware and normal firmware. The solution they suggest is to click
> >  'restore default config' but this does nothing on my slug but bring
> >  the same error message up again.
>
> Hi,
>
> you should try to reset your SysConf area, reflash the original Linksys
> firmware and then restore the default configuration. This is
probably the
> safest way to recover from your situation. This is what you will need to
> do, with links to the appropriate wiki pages that describe each step:
>
> 1. Telnet into Redboot, according to the instructions at
>   http://www.nslu2-linux.org/wiki/HowTo/TelnetIntoRedBoot
>
> 2. Erase the Sysconf partition. Be very careful at this step, a typo
in the

>   "fis erase" command can damage other areas in the flash and prevent
>   the slug from booting. See
> http://www.nslu2-linux.org/wiki/HowTo/ResetSysConf.
>
> 3. Reflash the original Linksys firmware, according to
>   http://www.nslu2-linux.org/wiki/HowTo/RevertToLinksysFirmware
>
> 4. Log in into the Linksys web interface and restore default settings.
>
> From this point on, you should have the web interface working ok. After
> that, feel free to install Unslung.
>
> >  On another note if anyone know how I can recover the files off my old
> >  drive which has a corrupted EXT3 filesystem (I'm especially after
conf
> >  files which took ages to set up first time round) then please
advise me.
>
> If you have a Linux machine, simply attach the drive to it and run
fsck. If
> you don't have a Linux box, get a live CD from Ubuntu, boot from it and
> you will be able to run fsck on your drive. Please remember that
fsck can
> only fix the structure of the file system, there is no guarantee
that you
> will get all your data back, but it is your best bet.
>
> Regards,
>
> --
> Fernando Carolo
> "Ignore the noise. Make some signal" -- Nathan Torkington
>

Thanks Fernando. The process is a bit long winded but did the job in
the end. Everything is back up now and the slug is slowly being
restored to it's old self!

Cheers.


Reply | Threaded
Open this post in threaded view
|

Re: Re: Urgent help needed: fail to get samba information error

Fernando Carolo
On Mon, Feb 25, 2008 at 6:34 AM, raspden <[hidden email]> wrote:
> --- In [hidden email], "Fernando Carolo" <carolo@...> wrote:
>
>  Thanks Fernando. The process is a bit long winded but did the job in
>  the end. Everything is back up now and the slug is slowly being
>  restored to it's old self!
>

I am glad that it worked. It is indeed a long process, but it is know to fix
this kind of problem with no side effects, so we always recommend it.

Good luck!

--
Fernando Carolo
"Ignore the noise. Make some signal" -- Nathan Torkington
Reply | Threaded
Open this post in threaded view
|

Re: Re: Urgent help needed: fail to get samba information error

ab500
This post has NOT been accepted by the mailing list yet.
Hi, Roberto. I followed your instructions trying to fix my NAS200; however, I can't make fis erase command to work. is there a way around? thank you.
Reply | Threaded
Open this post in threaded view
|

Re: Re: Urgent help needed: fail to get samba information error

ab500
This post has NOT been accepted by the mailing list yet.
oops... I don't know where I got the name Fernando from!!!. I meant Roberto :.) sorry...
Reply | Threaded
Open this post in threaded view
|

Re: Re: Urgent help needed: fail to get samba information error

ab500
This post has NOT been accepted by the mailing list yet.
better if I shut up... FERNANDO!!!